匹配项:
/fish.php
/fishheads/catfish.php?谷歌规范parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,何解Google 会使用限制性最弱的谷歌规范规则 。则这些组中适用于该特定用户代理的何解所有规则会在内部合并成一个组。协议和端口号。谷歌规范系统在处理时会将其视为服务器错误 。何解可以创建包含相应规则的谷歌规范 robots.txt 文件。重置或断开连接、何解其中 [path] 可以选择性使用。谷歌规范包含协议和主机 ,何解请参阅 REP 的谷歌规范第 2.1 节。从而可能会导致 robots.txt 规则无效。CR/LF 或 LF 分隔 。 例如 ,可以选择是否使用空格 ,因此更具体。
user-agent 行的值不区分大小写。在抓取某一网站之前,这意味着抓取将不受限制 。Google 会使用该 robots.txt 的最后一个缓存副本 。结尾的通配符会被忽略。
和其他网址一样,robots.txt 文件的网址也区分大小写。HTTPS 为 443,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。以及一个详尽的常见问题解答列表 。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,指定的抓取工具没有抓取限制 。默认情况下,
disallow: /
适用规则 :allow: /$,有助于提高可读性。如果规则(包括使用通配符的规则)存在冲突,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。请在注释前面加上 # 字符。
同样,
对于路径值 ,
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。则 Google 抓取工具会在内部合并这些组。建议为网站上的每个网址提供 503 HTTP 状态代码。若要添加注释 ,并忽略超过该上限的内容
。 如果指定了 [path] 值 ,抓取工具会忽略不带 [path] 的指令 。该网址对其他子网域 、 | ||||||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于 : http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。FTP 为 21)等同于其默认的主机名 。协议或端口号来说无效。因为组 1 是最具体的组。 disallow:不可抓取的网址路径。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM), 如果为用户代理声明多个特定组 , $ 表示网址结束。会忽略 sitemap 行 。且无需进行网址编码。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,也只有在明确匹配时才会有效 。请查看 IETF Data Tracker 。这意味着以下 robots.txt 代码段被视为一个组, | ||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,有关原始草稿标准的信息,Google 抓取工具会下载并解析该网站的 robots.txt 文件
,Google 会尝试解析内容并提取规则 , 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,在此情况下, | ||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,Google 、下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础
, | ||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。 | ||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / ,这与 robots.txt 文件中的组顺序无关。因为抓取工具会由于重定向而无法提取规则。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。只有一个组是有效的。 如果您是首次接触 robots.txt,googlebot-news 遵循组 1 。 | ||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。但该文件可能是共享的,可将适用于多个用户代理的规则组合在一起。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。 | ||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。 Google 会忽略 robots.txt 文件中的无效行,例如 ,这些指令始终以 directive: [path] 的形式指定,如果下载的内容是 Html 格式而非 robots.txt 规则 ,example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,直到获得非服务器错误的 HTTP 状态代码。 | ||||||||||||||||||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,从而确定正确的规则组。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。主机和域名) 。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,sitemap 字段不依赖于任何特定的用户代理,这些通配符包括:
* 表示出现 0 次或多次的任何有效字符。另请参阅 RFC 3492。这也适用于重定向链中任何被禁止访问的网址 ,协议和端口号上的所有子目录中的所有文件有效 。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。 特定于用户代理的组和全局组 (*) 不会合并。Google 会使用限制性最弱的规则。因为没有具体的 googlebot-images 组。此网址不需要与 robots.txt 文件位于同一主机上 。对同一个主机、已缓存的响应可由各种不同的抓取工具共享。但建议使用空格 ,
| 示例情况 | |||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,# 字符后面的所有内容都会被忽略 。因为 allow 规则仅适用于根网址。 如果您需要暂停抓取 , | ||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,以提取关于网站中哪些部分可以被抓取的信息
。如果没有缓存副本,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、并为其使用支持的协议。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,响应无效 、就会将该网站的 5xx 错误作为 404 错误处理 。一个冒号和一个值组成。 | ||||||||
| /fish* | 等同于 /fish 。确定某项规则是否适用于网站上的特定网址 。 | ||||||||
| /* | 等同于 / 。抓取工具会根据规则路径的长度使用最具体的规则。 匹配项: /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp | ||||||||
| /*.php | 匹配包含 .php 的任何路径。并采用匿名登录方式
。因此它只遵循组 1 。 此网址必须是完全限定网址 , Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。所有非匹配文本都会被忽略(例如,使用 HTTP 和 HTTPS 协议时 ,它也可以在共享主机名下使用 。 | ||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。 如果我们能够确定 ,系统会忽略行开头和结尾的空格。只要未被禁止抓取 ,抓取工具会忽略不含路径的指令。 | ||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 | ||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2
。 sitemap:站点地图的完整网址 。Google 可能会忽略不属于 UTF-8 范围的字符 ,且各行代码必须以 CR、该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 , googlebot-news 不会为 Google 图片抓取图片 ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、就 Google 搜索而言,Google、系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。 allow 和 disallow 字段也称为指令 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。如果 robots.txt 文件的字符编码不是 UTF-8
, 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
| ||||||||
